Malaysian Registration Lookup Service Outage

Incident Report for AutoGrab

Resolved

This incident has been resolved.
Posted Jul 21, 2026 - 10:39 AEST

Identified

We've identified an issue causing registration lookups to fail in app. API is still available.
Posted Jul 21, 2026 - 10:31 AEST
This incident affected: Registration & VIN Search (Malaysia).