Processing Delays

Incident Report for AutoGrab

Resolved

We believe the issue has now been resolved.
Posted Apr 02, 2025 - 14:04 AEDT

Investigating

We're currently experiencing delays in data processing which may affect user experience. During this time leads may take longer than usual to appear within the application.
Posted Apr 02, 2025 - 14:01 AEDT
This incident affected: Sourcing (Australia) and Alerts & Notifications (Australia).