Processing Delays
Incident Report for AutoGrab
Resolved
We believe the issue has now been resolved.
Posted Nov 13, 2024 - 22:59 AEDT
Investigating
We're currently experiencing delays in data processing which may affect user experience. During this time leads may take longer than usual to appear within the application.
Posted Nov 13, 2024 - 22:32 AEDT
This incident affected: Sourcing (Australia) and Alerts & Notifications (Australia).