Processing Delays

Incident Report for AutoGrab

Resolved

We believe the issue has now been resolved.
Posted May 13, 2024 - 14:17 AEST

Investigating

We're currently experiencing delays in data processing which may affect user experience. During this time leads may take longer than usual to appear within the application.
Posted May 13, 2024 - 14:16 AEST
This incident affected: Sourcing (Australia) and Alerts & Notifications (Australia).