AutoGrab - Bad Request

Incident Report for AutoGrab

Resolved

The incident has been resolved and services restored.
Posted Jul 07, 2025 - 09:44 AEST

Identified

AutoGrab has identified an issue where some users are receiving the Bad Request Error when trying to log in. We are currently working on a fix
Posted Jul 07, 2025 - 09:38 AEST
This incident affected: Sourcing (Australia), Customer Recapture (Australia), Fleet (Australia), Pre Accident Valuation & Insurance (Australia), and Registration & VIN Search (Australia).