Some users unable to access AutoGrab UK.

Incident Report for AutoGrab

Resolved

This incident has been resolved.
Posted Nov 03, 2025 - 16:14 AEDT

Update

We are continuing to work on a fix for this issue.
Posted Nov 03, 2025 - 16:02 AEDT

Identified

We're aware some UK users are not able to access the app currently. The issue has been identified and we are working on a fix
Posted Nov 03, 2025 - 15:57 AEDT
This incident affected: Sourcing (United Kingdom), Realtime Pricing & Models (United Kingdom), Fleet (United Kingdom), Registration & VIN Search (United Kingdom), and Pre Accident Valuation & Insurance (United Kingdom).