Pricing Delays

Incident Report for AutoGrab

Resolved

This incident has been resolved.
Posted Jun 11, 2026 - 21:29 AEST

Identified

We have identified delays in the response to pricing requests in app and via API.
Posted Jun 11, 2026 - 20:58 AEST
This incident affected: Realtime Pricing & Models (Australia, Malaysia).