Upstream Rego and VIN lookup quality degradation

Incident Report for AutoGrab

Resolved

This incident has been resolved.
Posted Jun 15, 2026 - 11:46 AEST

Update

We are continuing to work with our upstream provider to provide a resolution.
Posted Jun 15, 2026 - 10:49 AEST

Identified

We have reverted to our redundant provider and the service is partially restored. We will update again when we revert to our primary provider.
Posted Jun 15, 2026 - 10:07 AEST

Investigating

We are currently investigating an issue with reduced quality results from our upstream provider.
Posted Jun 15, 2026 - 09:54 AEST
This incident affected: Registration & VIN Search (Australia).