Valuation Latency & Failures

Incident Report for AutoGrab

Resolved

This incident has been resolved.
Posted Feb 19, 2026 - 11:49 AEDT

Identified

We have identified an issue causing valuation responses to be slow or fail. We are aware an implementing steps to mitigate and resolve.
Posted Feb 19, 2026 - 11:40 AEDT
This incident affected: Realtime Pricing & Models (Australia, New Zealand, Malaysia, United Kingdom).