Pricing App Stability Issues

Incident Report for AutoGrab

Resolved

We have resolved the issue and are now monitoring over the next hour to ensure full resolution.
Posted Jun 30, 2025 - 09:21 AEST

Update

We are continuing to work on a fix for this issue.
Posted Jun 30, 2025 - 09:10 AEST

Identified

We have identified the root cause and are working on a resolution.
Posted Jun 30, 2025 - 09:07 AEST

Investigating

We are having some issues across the AutoGrab app. Please bear with us while we investigate.
Posted Jun 30, 2025 - 09:01 AEST
This incident affected: Sourcing (Australia, Malaysia), Realtime Pricing & Models (Australia, Malaysia), and Pre Accident Valuation & Insurance (Australia, Malaysia).