Malaysian Fleet Lookup Outage

Incident Report for AutoGrab

Resolved

This incident has been resolved.
Posted Jul 01, 2025 - 10:55 AEST

Investigating

We have identified an error affecting the Fleet Pricing application, currently isolated to Malaysia. Our team is actively working on a resolution.
Posted Jul 01, 2025 - 09:54 AEST
This incident affected: Fleet (Malaysia).